0%

PAT-1008 Elevator (20)

PAT-1008 Elevator

1008. Elevator (20)
时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:
3 2 3 1
Sample Output:
41

超级简单的题目,但是我第一遍翻车了QAQ,仔细思考发现漏了一种情况,就是两个zz的目的地是同一楼层,但是他不下电梯,所以电梯会继续停留5秒在当前楼层,for example:

input: 3 2 3 3 1 output: 33

ps:还要注意这个题目的默认楼层是0层...

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
#include <iostream>

using namespace std;


int main()
{
int n;
cin>>n;
int temp,sum=0,localfloor=0,upordown=0;
for(int i=0;i<n;i++)
{
cin>>temp;
if(localfloor<temp)
{
sum+=(temp-localfloor)*6+5;
localfloor=temp;
}
else if(localfloor>temp)
{
sum+=(localfloor-temp)*4+5;
localfloor=temp;
}
else
{
sum+=5;
localfloor=temp;
}
}
cout<<sum<<endl;
}

丑点是丑了点,但是简单易懂啊:smiley: